CSP API: System Busy

Incident Report for Campaign Registry

Resolved

The intermittent high load issue that was causing some queries to time out should be resolved now. We will continue to monitor, but will close out this incident for now. If you are still seeing issues, please open a support ticket (support@campignregistry.com)
Posted Feb 05, 2026 - 18:23 EST

Investigating

We have received some reports of users receiving some 400 responses (System Busy) in the CSP API. We are currently investigating this as a top priority and will update here as we get new information.
Posted Feb 05, 2026 - 14:51 EST
This incident affected: API (csp-api).